?

Linux

Management
Joined
Jan 28, 2013
Messages
1,685
Likes
211
#2
It does, every system is made to support older apps. But run it in compatibility mode just to be sure SWAT doesn't lag or something.

If you wanna, you can add me on Steam or Xfire and we can talk more about it.

By the way, why installing dead game? :p
 

Xavii

Senior Admin
Joined
Jan 4, 2009
Messages
5,133
Likes
463
#3
Linux said:
It does, every system is made to support older apps. But run it in compatibility mode just to be sure SWAT doesn't lag or something.

If you wanna, you can add me on Steam or Xfire and we can talk more about it.

By the way, why installing dead game? :p
he's installing SWAT, so please, RESPECT!
 

Who is viewing this thread (Total: 1, Members: 0, Guests: 1)